DSCP (QOS) Settings Explained
Hawkeye implements Class of Service based on DSCP setting. The following table details table name and different settings (as explained in following section) correspondence.
| DSCP Class | DSCP (bin) | DSCP (hex) | DSCP (dec) | ToS (dec) | ToS (hex) | ToS (bin) | ToS Prec. (bin) | ToS Prec. (dec) | ToS Delay Flag | ToS Throghput Flag | ToS Reliability Flag | TOS String Format |
|---|---|---|---|---|---|---|---|---|---|---|---|---|
| none | 000000 | 0×00 | 0 | 0 | 0×00 | 00000000 | 000 | 0 | 0 | 0 | 0 | Routine |
| cs1 | 001000 | 0×08 | 8 | 32 | 0×20 | 00100000 | 001 | 1 | 0 | 0 | 0 | Priority |
| af11 | 001010 | 0×0A | 10 | 40 | 0×28 | 00101000 | 001 | 1 | 0 | 1 | 0 | Priority |
| af12 | 001100 | 0×0C | 12 | 48 | 0×30 | 00110000 | 001 | 1 | 1 | 0 | 0 | Priority |
| af13 | 001110 | 0×0E | 14 | 56 | 0×38 | 00111000 | 001 | 1 | 1 | 1 | 0 | Priority |
| cs2 | 010000 | 0×10 | 16 | 64 | 0×40 | 01000000 | 010 | 2 | 0 | 0 | 0 | Immediate |
| af21 | 010010 | 0×12 | 18 | 72 | 0×48 | 01001000 | 010 | 2 | 0 | 1 | 0 | Immediate |
| af22 | 010100 | 0×14 | 20 | 80 | 0×50 | 01010000 | 010 | 2 | 1 | 0 | 0 | Immediate |
| af23 | 010110 | 0×16 | 22 | 88 | 0×58 | 01011000 | 010 | 2 | 1 | 1 | 0 | Immediate |
| cs3 | 011000 | 0×18 | 24 | 96 | 0×60 | 01100000 | 011 | 3 | 0 | 0 | 0 | Flash |
| af31 | 011010 | 0×1A | 26 | 104 | 0×68 | 01101000 | 011 | 3 | 0 | 1 | 0 | Flash |
| af32 | 011100 | 0×1C | 28 | 112 | 0×70 | 01110000 | 011 | 3 | 1 | 0 | 0 | Flash |
| af33 | 011110 | 0×1E | 30 | 120 | 0×78 | 01111000 | 011 | 3 | 1 | 1 | 0 | Flash |
| cs4 | 100000 | 0×20 | 32 | 128 | 0×80 | 10000000 | 100 | 4 | 0 | 0 | 0 | FlashOverride |
| af41 | 100010 | 0×22 | 34 | 136 | 0×88 | 10001000 | 100 | 4 | 0 | 1 | 0 | FlashOverride |
| af42 | 100100 | 0×34 | 36 | 144 | 0×90 | 10010000 | 100 | 4 | 1 | 0 | 0 | FlashOverride |
| af43 | 100110 | 0×26 | 38 | 152 | 0×98 | 10011000 | 100 | 4 | 1 | 1 | 0 | FlashOverride |
| cs5 | 101000 | 0×28 | 40 | 160 | 0xA0 | 10100000 | 101 | 5 | 0 | 0 | 0 | Critical |
| ef | 101110 | 0×2E | 46 | 184 | 0xB8 | 10111000 | 101 | 5 | 1 | 1 | 0 | Critical |
| cs6 | 110000 | 0×30 | 48 | 192 | 0xC0 | 11000000 | 110 | 6 | 0 | 0 | 0 | Internetworkcontrol |
| cs7 | 111000 | 0×38 | 56 | 224 | 0xE0 | 11100000 | 111 | 7 | 0 | 0 | 0 | Networkcontrol |
Details on Class of Service - Different Standards
IP TOS
The type-of-service (TOS) byte in an IP header specifies traffic precedence and type of service (as defined in RFC 791 and RFC 1349). Figure 9-1 shows the TOS byte in the IP header.
The precedence field comprises the first three bits and supports eight levels of priority. The lowest priority is 0, the highest is 7 (values 6 and 7 are reserved for network control packets).
The precedence field setting
The four bits following the precedence field specify the type of service. Only one of these bits can be enabled at one time. Each bit defines the desired type of service:
- D – The delay bit instructs network devices to choose high speed to minimize delay.
- T – The throughput bit specifies high capacity links to ensure high throughput.
- R – The reliability bit specifies that reliable links should be used to minimize data loss.
- C – The cost bit specifies that data transmission should be accomplished at minimal cost.
The last bit in the TOS byte is reserved and is always set to 0.
On Microsoft Windows Server 2008 (32- and 64-bit) and on Microsoft Windows Vista (32- and 64-bit), IP TOS can be set only via qWave templates. If endpoints are used on these types of Operating systems, qwave needs to be installed so that the endpoint can tag with correct TOS.
DiffServ
Differentiated Services (DiffServ) is a QoS model defined by the IETF for IP networks (refer to RFC 2474). This model is designed to be scalable and to provide consistent service classes independent of application. DiffServ redefines the TOS byte of the IP header (see Figure 9-1) as the DS field.
The first six bits of the DS field are used as a differentiated service code point (DSCP), and the last two bits are currently unused (CU).
In the DiffServ QoS model, traffic is classified by marking the DS field with a DSCP value. Queuing mechanisms provide differentiated forwarding of the traffic at each hop, based on the DSCP value.
On Microsoft Windows Server 2008 (32- and 64-bit) and on Microsoft Windows Vista (32- and 64-bit), IP TOS can be set only via qWave templates. If endpoints are used on these types of Operating systems, qwave needs to be installed so that the endpoint can tag with correct DSCP.
Per-Hop Behavior (PHB)
The DSCP selects the Per-Hop Behavior (PHB) that a packet experiences at each node. RFC 2474 defines PHB as the externally observable forwarding behavior applied at a DiffServ-compliant node to a DiffServ Behavior Aggregate.
There are currently four standard PHBs:
- Default ("Best Effort") PHB (as defined in RFC 2474)
- Class-Selector PHB (as defined in RFC 2474)
- Assured Forwarding (AF) PHB (as defined in RFC 2597)
- Expedited Forwarding (EF) PHB (as defined in RFC 2598).
Default PHB
RFC 2474 recommends codepoint 000000 as the Default PHB.
Class-Selector PHBs
RFC 2474 defines 21 codepoints, including the Class-Selector PHBs listed below:
Assured Forwarding (AF) PHB
The Assured Forwarding (AF) PHB group provides delivery of IP packets in N independently forwarded AF classes. Within each AF class, an IP packet can be assigned one of M different levels of drop precedence. Currently, four classes with three levels of drop precedence in each class are defined for general use. (Additional AF classes or levels of drop precedence may be defined for local use.)
RFC 2597 recommends the codepoints described below.
This table shows each of the AFMN bit values, where M is the AF class and N is the drop precedence. In list form, these are:
- AF11 = 001010
- AF12 = 001100
- AF13 = 001110
- AF21 = 010010
- AF22 = 010100
- AF23 = 010110
- AF31 = 011010
- AF32 = 011100
- AF33 = 011110
- AF41 = 100010
- AF42 = 100100
- AF43 = 100110
Expedited Forwarding (EF) PHB
RFC 2598 defines the EF PHB as a as a PHB that can be used to build a low loss, low latency, low jitter, assured bandwidth, end-to-end service through DS domains. RFC 2598 recommends codepoint 101110 as the default EF PHB.