Supported Protocols and Standards

This section covers supported protocols and standards by Hawkeye.

Node to Node Tests
Transaction traffic Types Supported Traffic
Throughput measurements UDP / TCP
Voice G711, G729, AMR
Video MPEG2/MPEG4 – SD and HD
Signalling Voice SIP - H323
Emails POP3, SMTP, Exchange
WWW HTTP, HTTPs, FTP, DNS, Telnet
Office 365 Exchange, Skype4B media
Real Service Tests - One Arm
One arm traffic Details
Bittorrent Download torrent
DNS Verify DNS server response time
DropBox Download/upload files
Email Send/receive emails (SMTP, IMAP, POP3)
FTP Download/upload files to server
HTTP/HTTPS Download/check page availability
ICMP Advanced ping metrics
IGMP v2/v3 Join/leave Multicast and measure metrics
SpeedTest Validate Speedtest up/down from 4000+ servers
TCP/UDP ping Ping using TCP or UDP protocols
Traceroute Trace routes to remote hosts
Supported Standards
Node to Node
Protocol Standard
IP TOS RFC 791 y RFC 1349
Diffserv RFC 2474, RFC 2597, RFC 2598
UDP RFC 768 or proprietary
TCP window scale RFC1323
TCP window retransmission RFC1122
RTP RFC3550
Real Services  
Protocol Standard
HTTP RFC2616
HTTPS RFC2818
FTP RFC959
DNS RFC1034, RFC1035
ICMP RFC792
Traceroute RFC1393
Peer to Peer RFC5694
SMTP RFC821, RFC2821
POP3 RFC1939
Testing  
Metric Standard
Throughput (goodput) RFC2647
Jitter RFC1889
video MDI (DF, MLR) RFC 4445
MOS ITU.G107
R Factor ITU.G107 (E-model)
Benchmarking, service activation RFC2544
Web Server notification  
Protocol Standard
SMTP (email notification) RFC821, RFC2821
SNMP RFC1157

Supported Voice over IP Codecs